Svenska Orienteringsförbundet

Inlägg i OLA > Webgränssnitt till OLA - applikationen vill inte starta

  • Stefan Månsson
    tisdag 9 maj 2017 klockan 14:13

    Fick ett annat tips som även det fungerar. I OLA server finns en flik "Proxy inställningar", om man där anger den ip-adress och port som man vill att OLA-server använder innan man trycker på "Start" så används de inställningarna före alla andra ip-adresser som existerar på servern.

  • Fredric Johansson
    tisdag 9 maj 2017 klockan 11:01

    Det du exempelvis kan göra är att inaktivera Virtualboxs nätverkskort om du inte kommer köra det samtidigt.

  • Stefan Månsson
    måndag 8 maj 2017 klockan 17:08

    Magnus > Vet du om det finns någon sätt att komma runt problemet när man har exempelvis Virtualbox installerad och ip-adressen för virtuella nätverket visas först i OLA-server?

    Tänkte om man kan slippa att avinstallera Virtualbox på datorn som är tänkt att använda som server på en av försommarens tävlingar. 

  • Magnus Johansson
    tisdag 6 oktober 2015 klockan 9:38

    I OLA Server så kan man se vilka IP-adresser som den binder till i inforaden direkt under menyraden. Det fungerar bara att köra via webbstart om man anslutit till den ip-adress som står först.

    Om du från en klientdator surfat till OLA server via en annan ip-adress än den första så kommer du få ett fel, som jag har för mig ser ut som det du beskriver.

    Det kan bli fel t ex om du har dubbla ip-adresser på dit nätverkskort, eller har flera nätverkskort. Jag själv har fått problem för att jag haft virtuella nätverkskort (från VirtualBox) vars ip-adress råkat hamna före i listan.

  • Stefan Kinell
    lördag 3 oktober 2015 klockan 10:02

    Hej,

    IP-numret för serven funkar från vanliga Ola-klienterna som är på nätverket. Vi kör bara trådat nätverk. Web-klienten vill vi köra för att kunna ha fler datorer som backuplösning om vi har för mycket att göra ;-)

  • Peter Löfås
    onsdag 30 september 2015 klockan 22:36

    Kolla så du inte har både trådbundet och trådlöst nätverk igång på servern. Ola Server binder bara mot ett IP-nummer av dessa, och klienter kan bli förvirrade. 

    Du måsten även starta om Ola Server ifall din dator fått nytt IP-Nummer

  • Gunnar Svanberg
    onsdag 30 september 2015 klockan 22:24

    Är OLA Server startad?

    Är rätt port (8080) angiven i OLA Server?

    Är det rätt ip-adress på servern?

  • Stefan Kinell
    onsdag 30 september 2015 klockan 21:06

    Hej,

    Jag försöker få igång webgränssnittet till OLA inför helgens tävling och får felmedelande att det inte går att starta applikationen. Det jag gör är att jag går till http://server.ip:port/client.html -> Klickar på "starta OLA-klient" -> filen ClientJnlpServlet.jnlp laddas ner -> öppnar den filen -> felmeddelande visas.

    Java är uppdaterat, får samma fel både på windows-maskin och en mac. Mer detaljer om felmeddelandet kan läsas nedan. Eller gör jag helt enkelt fel i stegen ovan? 

    com.sun.deploy.net.FailedDownloadException: Unable to load resource: http://192.168.1.69:8080/servlet/ClientJnlpServlet?eventId=1&databaseName='2015HostBudkavle'
    at com.sun.deploy.net.DownloadEngine.actionDownload(Unknown Source)
    at com.sun.deploy.net.DownloadEngine.downloadResource(Unknown Source)
    at com.sun.deploy.cache.ResourceProviderImpl.getResource(Unknown Source)
    at com.sun.deploy.cache.ResourceProviderImpl.getResource(Unknown Source)
    at com.sun.javaws.Launcher.updateFinalLaunchDesc(Unknown Source)
    at com.sun.javaws.Launcher.prepareToLaunch(Unknown Source)
    at com.sun.javaws.Launcher.prepareToLaunch(Unknown Source)
    at com.sun.javaws.Launcher.launch(Unknown Source)
    at com.sun.javaws.Main.launchApp(Unknown Source)
    at com.sun.javaws.Main.continueInSecureThread(Unknown Source)
    at com.sun.javaws.Main.access$000(Unknown Source)
    at com.sun.javaws.Main$1.run(Unknown Source)
    at java.lang.Thread.run(Thread.java:745)

     

    Tack

    Stefan

Annonser

Orienteringsmagasinet 1 kr
Skåne OF