Svenska Orienteringsförbundet

Inlägg i OLA > Å Ä Ö

  • Oskar Berg
    fredag 18 mars 2016 klockan 10:49

    Nu har Henrik löst det. Problemet är att filerna i Windows skapas i iso-kodning medans OLA talar om i resultatfilen att den ska tolkas som UTF-8. För att åtgärda detta så kan ni lägga till en parameter till starten av OLA-server. Den parametern kommer att vara standard i nästa version av OLA. Parametern är:

    -Dfile.encoding=utf8

    Detta innebär att OLA kommer att skapa UTF-8 filer.

    Högerklicka på ikonen för OLA-server och ta Egenskaper och se till att "Mål" ser ut som följer:

    "C:\Program Files (x86)\OLA 5.3\jre8\bin\javaw.exe" -Djava.library.path=lib -Dfile.encoding=utf8 -Xmx1024m -splash:./webpages/Images/svenskorientering.gif -cp lib\olaserver.jar;lib\* soft.ola.server.Server

     

    Sen funkar det kanon!

    Ett tillägg, om du har Windows 10 så kunde åtminstone inte jag högerklicka direkt på ikonen i startmenyn, jag fick högerklicka på den i menyn och välja "Öpppna filsökväg" och sedan där högerklicka på den igen och ta egenskaper.

    Mvh Oskar

  • Oskar Berg
    fredag 18 mars 2016 klockan 10:43

    @Pebe-> Vore intresant att höra vad det är som inte funkar med OLresultat? Har du mer detaljer?

  • Markus Almgren
    söndag 14 februari 2016 klockan 22:10

    Hej, Felet är vad jag ser att resultaten för klasserna skapas med.

    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8">

    tidigare versioner av filerna har skapats med:

    <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">

    Ändrar man de befintliga html:en till tidigare kod så fungerar det. Dock så måste ju koden som skapar dessa filer ändras då det inte är något man kan ställa in i templates och skapas om med samma fel nästa gång koden genereras om.

     

  • Patrik Brorsson
    torsdag 21 januari 2016 klockan 14:06

    Är det någon i programmeringsgänget som jobbar med problemet nu? Det hade varit bra om det kunde ordnas så snart som möjligt inför vårens tävlingar...

  • Christoffer Olsson
    tisdag 19 januari 2016 klockan 18:24

    Tyvärr så får man ligga på för att kunna få fel åtgärdade

  • Torbjörn Ottosson
    tisdag 19 januari 2016 klockan 14:09

    Felanmälde detta till OLA supporten i oktober. Inte hört nåt om nån lösning ännu...

  • Christoffer Olsson
    tisdag 19 januari 2016 klockan 12:16

    Hmm, testade igen nu på en ny dator och den skapar korrekta filer med OLresultat, OLAs resultatfunktion genererar samma fel som ni pratar om. Vet inte varför de blir så, kör windows 7 pro på svenska

  • Gunnar Svanberg
    måndag 18 januari 2016 klockan 10:29

    Håller med Pebe, funkar varken med IE11, Edge eller Chrome.

  • Pebe
    måndag 18 januari 2016 klockan 8:57

    kag har testat även Oskars lösning med att ha senaste versionen men det fungerar inte det heller... Hur gör du Christoffer Olsson?

  • Christoffer Olsson
    fredag 30 oktober 2015 klockan 1:09

    Jag använder Oskar Bergs lösning som skapar korrekta filer :-)

  • Torbjörn Ottosson
    torsdag 29 oktober 2015 klockan 21:05

    Samma fel, både med IE11 och Edge. Kommer det en lösning snart? Vi har tävling om 2 veckor...

  • Magnus Jonasson
    torsdag 22 oktober 2015 klockan 16:04

    Testa med andra webbläsare.

  • Pebe
    torsdag 22 oktober 2015 klockan 13:36

    Använder ej webbläsare i tvn utan utökat skrivbord på datorn där jag öppnar htmlfilen i den delen av skrivbordet som är i tvn.

  • Magnus Jonasson
    torsdag 22 oktober 2015 klockan 11:58

    Eftersom filen som skapas är felaktig kan man antigen fixa den eller använda en webbläsare som är mer tolerant mot fel. Är det en inbyggd webbläsare i TV:n? Antagligen svårt att fixa i så fall, då får man vänta på ny version av OLA.

  • Pebe
    onsdag 21 oktober 2015 klockan 15:56

    är det ingen annan som har problemet och kan en lösning?

  • Pebe
    tisdag 13 oktober 2015 klockan 20:25

    jag kör med den senaste versionen av Ola men det fungerar ej. Men det stämmer det du säger att det är ett programmeringsfel. I koden i den skapade HTMLfilen så saknas ett situationstecken kring "utf-8" som gör att det blir fel. Om man korrigerar detta så visas det rätt, men bara fram till att servern uppdateras igen vilket sker erter det förinställda värdet i Ola server. Använder mig av utökat skrivbord till tv-skärm dit jag drar hrmlfilen, dvs använder ej webbläsare i tvn. 

  • Oskar Berg
    tisdag 13 oktober 2015 klockan 19:11

    Det finns en bugg i webresultat-delen. Kör senaste versionen av OLA så bör det funka. 5.3.0-23 tror jag det är...

  • Felix Alnervik
    tisdag 13 oktober 2015 klockan 14:02

    kan mycket väl vara webläsaren i TVn som ej kan tolka Å Ä Ö
    går säkert att justera i HTML filerna eller liknande

  • Pebe
    måndag 12 oktober 2015 klockan 23:45

    Vid visning av Webresultat i TV-skärm visas ej Å Ä Ö utan istället en romb med frågetecken i. Hur löser man det?

Annonser

Skåne OF
Orienteringsmagasinet 1 kr