Svenska Orienteringsförbundet

Inlägg i OLA > Uppdatera databasversion

  • Pär Moqvist
    söndag 22 april 2018 klockan 20:58

    Fick liknande problem innan jag uppgraderade till 5.5.0. Trevligt om någon kunde ta bort 5.4.1-10 eller informera om detta.

  • Per Damberg
    söndag 8 april 2018 klockan 16:44

    När jag skapar en ny tävling med lokal databas (lokal eller från Eventor) får jag följande logg:

    2018-04-08 16:34:32: OLA 5.4.1-10 started
    Windows 7
    org.h2.jdbc.JdbcSQLException: User or role "LIVE" not found; SQL statement:
    GRANT READONLY TO live [90071-176]
     at org.h2.message.DbException.getJdbcSQLException(DbException.java:344)
     at org.h2.message.DbException.get(DbException.java:178)
     at org.h2.message.DbException.get(DbException.java:154)
     at org.h2.command.ddl.GrantRevoke.setGranteeName(GrantRevoke.java:72)
     at org.h2.command.Parser.parseGrantRevoke(Parser.java:4239)
     at org.h2.command.Parser.parsePrepared(Parser.java:390)
     at org.h2.command.Parser.parse(Parser.java:306)
     at org.h2.command.Parser.parse(Parser.java:278)
     at org.h2.command.Parser.prepareCommand(Parser.java:243)
     at org.h2.engine.Session.prepareLocal(Session.java:442)
     at org.h2.engine.Session.prepareCommand(Session.java:384)
     at org.h2.jdbc.JdbcConnection.prepareCommand(JdbcConnection.java:1188)
     at org.h2.jdbc.JdbcStatement.executeInternal(JdbcStatement.java:172)
     at org.h2.jdbc.JdbcStatement.execute(JdbcStatement.java:160)
     at soft.ola.gui.wizard.CreateEventUtil.createEmbeddedDatabase(CreateEventUtil.java:111)
     at soft.ola.gui.wizard.CreateEventUtil.createEvent(CreateEventUtil.java:46)
     at soft.ola.gui.wizard.newevent.CreateEventLocalStatusDescriptor$1.run(CreateEventLocalStatusDescriptor.java:60)
    2018-04-08 16:35:28: OLA stopped

    Det säger mig tyvärr inte om det har med den felaktiga databasversionen att göra, men kanske någon annan?

    Angående problem med att sedan uppgradera databasen står på Eventors välkomstsida under "Meddelanden":

    "Det går fortfarande inte att uppgradera den inbyggda databasen i OLA till en nyare. Nya tävlingar kan utan problem skapas i den senaste versionen."

     

  • Fredric Johansson
    fredag 6 april 2018 klockan 11:52

    När jag skapar ny tävling med inbyggda databasen så händer samma sak att den har version 559. Jag tror det beror på att filen som den interna databasen skapas ifrån inte är uppdaterad till 560.

    Uppdateringen ska fungera bra. Kolla logg-filerna (C:\ProgramData\OLA5\log) om det står något där

  • Per Damberg
    torsdag 5 april 2018 klockan 17:52

    Jag såg nu att det är ett känt faktum att det inte går att uppgradera databasen men frågan varför nya tävlingar som jag skapar får den gamla versionen kvarstår.

  • Per Damberg
    torsdag 5 april 2018 klockan 16:41

    Jag försöker skapa en tävling med den inbyggda databasen och har installerat 5.4.1-10 på server-PCn. Oavsett om jag skapar en lokal tävling eller importerar från Eventor får tävlingen databasversion 559 men OLA kräver 560.

    Som jag läst i en annan tråd skall jag då gå in i OLAserver och gå till Databasverktyg-->Databasinställningar-->Markera databasen och trycka "Uppdatera".

    När jag gör detta hamnar stapeln på 96% direkt och sedan händer inget mer. Jag har låtit programmet stå på över natten utan något mer resultat.

    Jag har avinstallerat, raderat alla tänkbara berörda filer och ominstallerat OLA, utan att det hjälper.

    Vad gör jag för fel?

Annonser

Orienteringsmagasinet 1 kr
Skåne OF