Svenska Orienteringsförbundet

Inlägg i OLA > Import av banor och kontroller

  • Hans-Olof Fröjd
    tisdag 1 september 2015 klockan 22:33

    Purple Pen.
    Försökte importera (IOF xml) kontroller och banor. Ingenting  hände, varken data eller felmeddelande. Jfr med OCAD,  som hade xml ver 3.0, medan PP hade 2 någonting. Troligen orsaken, men hittade ingen uppgift vad OLA accepterar.
    Men, konstigt att jag inte fick  något felmeddelande.

  • Felix Alnervik
    torsdag 19 juni 2014 klockan 16:39

    Med OCAD blir det så här

    <ClassCourseAssignment>
    <ClassName>H20</ClassName>
    <CourseName>Bana 2</CourseName>
    </ClassCourseAssignment>
    <ClassCourseAssignment>
    <ClassName>H40</ClassName>
    <CourseName>Bana 3</CourseName>
    </ClassCourseAssignment>
    <ClassCourseAssignment>
    <ClassName>D35</ClassName>
    <CourseName>Bana 3</CourseName>
    </ClassCourseAssignment>
    <ClassCourseAssignment>
    <ClassName>D20</ClassName>
    <CourseName>Bana 3</CourseName>
    </ClassCourseAssignment>

    och det fungerar uppenbarligen...

  • Felix Alnervik
    torsdag 19 juni 2014 klockan 16:37

    Råkade idag ut för att Condes slår ihop kopplingarna mellan Bana och klass.

    <Course>
    <CourseName>Bane 3</CourseName>
    <CourseId>190</CourseId>
    <ClassShortName>D20</ClassShortName>
    <ClassShortName>D35</ClassShortName>
    <ClassShortName>H18</ClassShortName>
    <ClassShortName>H40</ClassShortName>
    <CourseVariation>

    Detta gör att endast den sista klassen, i detta fallet H40, blir kopplad till rätt bana i OLA.

  • Martin Nilsson
    onsdag 2 oktober 2013 klockan 21:13

    Hade ett annat problem vid SM stafett. Vår xml från OCAD innehöll drygt 1600 banor och var 8,5 MB stor. Många gafflingsalternativ... Ibland sa OLA att banan redan var inläst och man fick valet skriva över eller inte. Jag hittade inget orsak till detta. XML-en verkade frisk och det var inget speciellt med de banor som försvann. Tänker om just storleken kan vara ett bekymmer. Hade även problem med andra xml import/export som register, startlista, resultat mm.

  • Robert Johansson
    tisdag 1 oktober 2013 klockan 16:01

    Verkar som att importen antar att värdena av x och y på MapPosition-Elementen är på formatet: 23.23 och när de är på formatet 23,23 (komma istället för punkt) så misslyckas importen utan att säga något.

    Märkte detta när jag försökte importera en fil från Purple Pen. Vore fint om det kunde fixas även om det var lätt att fixa till filen innan import.

  • Peter Löfås
    söndag 29 maj 2011 klockan 21:58

    Lite praktiskt info vid import av banor och kontroller:

    Om du exporerar från Condes får du fel ang. ModifyDate, detta är rapporterat till Condes-teamet att de inte följer standard.

    OBS! Vid export från Condes
    Klicka ur "exportera stafettinformation"

    OLA verkar även kräva elementet <CourseId>, vilket Condes utelämnar om man inte klickar ur kryssrutan "utelämna CourseId" vid export i Condes.

  • Mats Lundman
    fredag 27 maj 2011 klockan 21:23

    Med Ocad 9 (eller 10) går det att göra xml-filer direkt som funkar.

  • Johan Wikner
    fredag 27 maj 2011 klockan 16:46

    Jag försöker importera banor från OCAD 8 till OLA 5.0-3 via Olahelper. Kontrollerna kommer in men inte banor eller klasskoppling. Fungerade 2008. Har någon en lösning snabbt?

  • Thomas Engberg
    onsdag 25 maj 2011 klockan 22:20

    Filen var hemmagjord (dvs inte exporterad från något program). Eftersom jag inte fick något felmeddelande vid importen och för att kontrollerna kom in men intebanorna eller kopplingen mellan banor och klasser så tänkte jag att filen stämde. Skall testa igen och se om det är något i filen ändå.

  • Henrik Bengtsson
    tisdag 24 maj 2011 klockan 16:27

    Nej, OLA har inga ytterligare krav. Har du gjort en XML-fil eller har du exporterat den från något program?

  • Thomas Engberg
    tisdag 24 maj 2011 klockan 10:54

    Har OLA andra krav på iof xml fil än vad dtd säger kring obligatoriska element för import av kontroller och banor? Jag gjorde en xml-fil med banor och kontroller, men OLA läste bara in kontrollerna, inte banorna eller kopplingen till klasser. Jag försökte med både klassens kortnamn och klassid (basid) för att få kopplingen att fungera.

  • Henrik Bengtsson
    söndag 22 maj 2011 klockan 8:20

    En annan lösning på det fall då man vill ha startstämpling men också starttid är att man lottar som vanligt och när man ska köra tävlingen ändrar man till stämpelstart. Då kommer OLA först kolla om det finns en startstämpel och ta den tiden. Om startstämpel saknas så tar man starttiden.

  • Mats Lundman
    lördag 21 maj 2011 klockan 19:06

    Det är den tidiga startbegränsningen som är för liten. Antagligen har startklockan gått före så att alla har startat för tidigt och därmed blivit diskade.

  • Magnus Forshällen
    fredag 20 maj 2011 klockan 17:46

    Jag satte kontrollerad stämpestart med tidsintervallet 0 och 0 sedan fick jag hela klubben diskad när vi läste in resultaten. Vi ändrade tiderna till 1 och 7200 utan märkbar förbättring. Alla startstämplade. Vi ändrade till kontrollerad startstämpling i respektive klass efter det vi lottat alla klasser. När vi utvärderade sträcktiderna så hade man rätt stämplar. Någon enhet  hade dock fel tid.

    Vad har vi gjot för fel.

  • Mats Lundman
    onsdag 18 maj 2011 klockan 11:56

    Nej, om man vill stor starttolerans så får man sätta höga värden på dessa begränsningar. Annars blir det tjuvstart eller sen start.

  • gsb
    onsdag 18 maj 2011 klockan 8:45

    Iofs fel ämne, men om man ställer bägge till 0, innebär det att det inte spelar någon roll hur långt före eller efter den lottade starttiden man startstämplar?

  • Mats Lundman
    onsdag 18 maj 2011 klockan 0:18

    Magnus>> Man använder startmetoden "kontrollerad stämpelstart" med tidig och sen startbegränsning.

  • Magnus Forshällen
    tisdag 17 maj 2011 klockan 21:37

    Hur ställer man in så att man vid start kan startstämpla och att startstämpeln gäller före den fasta starttid som är angivet i startlistan.

  • Gunnar Svanberg
    tisdag 17 maj 2011 klockan 15:51

    Det får bli så att jag tar bort raden.

  • Mats Troeng
    tisdag 17 maj 2011 klockan 15:31

    Filen följer inte XML-standarden. Så här borde det se ut:

         <ModifyDate>
          <Date dateFormat="YYYY-MM-SS">2011-05-17</Date>
          <Clock clockFormat="HH:MM:SS">06:43:23</Clock>
         </ModifyDate>

    Vill man få bort meddelandet kan man öppna filen i valfri kompetent texteditor och ta bort alla ModifyDate-element (som är valfria enligt standarden) genom att trixa lite med sök och ersätt och reguljära uttryck.

  • Gunnar Svanberg Järfälla OK
    tisdag 17 maj 2011 klockan 8:59

    När jag försöker importera en banfil från Condes (exporterad i IOF xml-format) så får jag alltid ett femeddelande om felaktigt "datumformat":
    "The content of element type "ModifyDate" must match "(Date,Clock?)"

    I min xml-fil ser det ut så här:
     <ModifyDate>2011-05-17 06:43:23</ModifyDate>

    Hur ska det se ut?

    Det fungerar, alla banor kommer in, om man klickar på Fortsätt, men det vore skönt att slippa meddelandet

Annonser

Skåne OF
Orienteringsmagasinet 1 kr